Editing posts not possible anymore

Tags: #<Tag:0x00007fd5e3c7f8d8> #<Tag:0x00007fd5e3c7f770>

We had problems editing post after discourse update, which have been resolved.
Actually @josefkreitmayer and @alabaeye had problems editing the first post of a thread using firefox or chrome on windows 7. The problem was found with AVAST antivirus software. As the antivirus software was replaced, the error did not appear any more.

apparently the error is still occuring.

@almereyda are the plugins already deactivated as suggested by the Discourse support (sorry for asking again). Probably if we tried and report that, they could suggest a next step.

I added @almereyda to the conversation in the discourse support.

update on describing the bug:

  • I just noticed, that any editing in the first post of a topic is not possible.
    Just now at 17:45 CEST, I tried to do a little edit on the initial post of this thread, which did not work, and I also tried at another first topic post, that did not work) Data(base) structure suggestion for SSEDAS
  • editing follwoing posts after the initial one in any topic is possible. The error message occurs, but the edit is accepted.
  • also bookmarking delivers the error message, but is accepted.

I have the same problem. Using latest Chrome and Windows 7.

more details: Editing is impossible on top posts as well as changing the title of thread/topic. Editing shows an error message on following posts, but actually happens…

Trying to edit using Firefox: result is exactly the same as with Chrome: error message but still edits (not for top posts though - tried unsucessfully on the top post of this thread…).

I just edited the first post using chrome on windows 7.
So it seems not to be a problem on all windows machines.

5 posts were split to a new topic: Spontaneous get together?

A post was merged into an existing topic: Linux Support

So I found the problem… :triumph: it’s Avast. That man in the middle thing is causing problems. Here is the post that identifies the bug: https://meta.discourse.org/t/post-editing-fails-sometimes/27330/32

Any recommendation in alternative to Avast? it’s been a while that I have been thinking of replacing it as it is a very demanding antivirus for my small machine.

3 Likes

A post was merged into an existing topic: Linux Support

Wow … another nice story to tell at the next CryptoParty!

Thanks for discovering this :smile:

Yeah, we found this when @alabaeye was making bank transactions next to me and asked if there was anything good or bad with the connection. I’ve checked the green EV certificate, which turned out to be from Avast instead of his bank. Felt totally super this moment.

2 Likes

7 posts were split to a new topic: Virus Scanners and Windows

2 posts were split to a new topic: Linux Support