Hackpad - Meeting minutes and other real-time notes

Hoppla: https://notes.transformap.co/

@toka @pmackay I believe I can create a stable Hackpad deployment now. To get around the notes two and three from the bottom of http://jimmyb.ninja/post/1447447641 I’ve created a fork which adds minor changes to support email.

If someone would donate an Amazon S3 bucket and sent me the credentials via a Private Message, I’d be happy to also connect Facebook and Google, finish some last customizations (on https://github.com/TransforMap/hackpad/blob/master/etherpad/etc/etherpad.local.properties.tmpl via https://github.com/TransforMap/hackpad/blob/master/bin/docker-entrypoint-without-mysql.sh) and get it up and running on docs.transformap.co or similar.

  • Google Log In not yet working.
  • Facebook Log In not yet working.
  • No image uploads possible (for now)

@toka @gandhiano @species @josefkreitmayer @alabaeye I suggest you stress-test this alpha service. If it passes, I think we should favour this service over text.allmende.io for meeting minutes.

Then we can adapt the landing page to our needs. The whole thing lives in Ecobytes’ Dokku, so we can always push changes without losing the application state.

Issues with the live deployment can go to https://github.com/TransforMap/hackpad/issues

2 Likes

502 :frowning:

Yeah, sorry, just migrated it from our old dokku-alt host to a new dokku machine to be able to run https://github.com/sgulseth/dokku-letsencrypt :wink:

Found few issues and resolve strategies:

So this is going to be a replacement for etherpad ?

Why is S3 needed for this?

Well, that’s how Hackpad is made.

Are you really saying hackpad (or some components) is designed in a way it only runs on proprietary privacy-invading other-people’s-computers (cloud)?

Vote against it for this feature in this case :-1: .

We could think of abstracting away their AWS dependency and use any S3 compatible object storage, instead. Like Ceph, Swift and the others.

The hackpad is currently offline and was offline several times in the last day.

I would strongly argue against that. We are using Etherpad now for several months, and it shows stability and ease of use.

Hackpad is now deployed since less than one month, and does not show stability. It has a slightly more demanding learning curve and several aspects that do not work as smoothly as they did in ehterpad (even though the look is more pleasant).

Hackpad or such is not on our list of deliverables to external partners, and we got lots to do. How much energy are we willing to invest, especially with respect of Jon being a main technical ressource as well as bottleneck for many developments we need.

Hackpad = nice to have.


Maybe my assumptions are wrong. Is someone else willing and able to invest time in a stable Hackpad infrastructure? That will definitely be of longterm benefit for Ecobytes as well as for the whole communities. @toka @pmackay @gandhiano @almereyda.

If there is no “yeah, let´s do that” from more than 1 person, I would suggest to ditch the effort for the moment.

The first real-world user tests (3 users) I did with our current hackpad implementation show exactly the contrary: people immediately started using, enjoyed the look and feel and the only complaint was about the non-working bold.

I would not put the effort as absolute priority, but I see it as a relatively stable (first) deployment, good enough to use within developer/pioneer users communities, such as in the context of TransforMap.

Opening to a larger public would require at least dealing with these issues:

  • session issue (if you are logged in, restart the computer or come at a later time, then you get this list of errors and need to logout and login again for it to work)
  • workspaces (either remove the possibility to create new and have only default ones, or get them to work automatically - this should actually be quite simple)

As for Amazon S3 and other third-party services, I think we could perspectively work to get over it, and I am sure hackpad will be transformed into proper free software by the developers community (where maybe we also contribute). If this is only relevant for people logging in through FB or Google, I wouldn’t even care about it (because they are already using proprietary services). If it affects the data we are all posting, then we should at least make sure that it goes there in an encrypted form.

[quote=“gandhiano, post:10, topic:832”]
session issue (if you are logged in, restart the computer or come at a later time, then you get this list of errors and need to logout and login again for it to work)
[/quote] @gandhiano @almereyda

I restarted the computer, and as well tried https://notes.transformap.co/ in another browser, but it does not react.


  • I see it the same, as @gandhiano describes (apart from it not working with me and not being the session issue described above), and am very happy, that he has positive experience with people using it.

  • I also kind of like it, and at the same time, currently would not like to have it as THE TOOL for “Meeting minutes and other real-time notes”, as it does not prove reliable for the moment and collaborative live notes are a core part of our workflow.


  • @almereyda, would it be ok for you to change the header of this topic to “hackpad deployment and testing phase” or such…? That would be to indicate, that this currently is not yet fit for being the main tool.

  • E.g. I will need a pad for mid of january for a call with 15 to 20 SSEDAS partners, and would like to have something stable to capture that, so please do not give up the effort to mentain http://text.allmende.io/ which proved stable for a quite long time.

I am happy, that 2 people @almereyda, @gandhiano are enthusiastic about hackpad.

Others? @toka @species @pmackay @alabaeye ?


+1


  • IMHO I think it is important, that we do not get side-tracked,

  • I suggest to write a change request/issue to the hackpad developers community and turn to our core project again, which is … gues what…

  • I also would consider it not our task to find out about it, and would suggest the same procedure:

write an issue to the hackpad developers community.

works for me. Got once some script. Had to to log out and log in again.

I very much like it and find it quite easy to use. More pleasant for the eyes than etherpad. However I wouldn’t beg for it. Happy to have it.

I tried it again today, and it worked as you said. It displayed the error messages (which I copied, if that is of help) but let me see parts of the main menu. I went to the segment “new hackpad” and it asked me, if I want to log in with another account. As I logged out and logged in again, now it works.

Why didn´t it work, and now it does?
Will that now keep running?
Is github a good place to put such issues?

@almereyda @gandhiano

If we have a fork on github for it (or are directly using one existing from there), that would be my preference to put issues on. I don’t know if that’s the case, so @almereyda should be the right person to clarify.

What are the benefits of hackpad over Etherpad others than eye-candy @almereyda @gandhiano?

My personal opinion is that we should stick with Etherpad for the moment because of “Never change a running system” and time imho is better invested elsewhere.

I just noticed with e.g. the checklist elements, there comes a funky new element e.g. to the standup minutes.

Originally I wanted to complain about the media breach. @gandhiano did the standup alone this friday (pitty on the rest of us) and started the pad in hackpad. First I was … “oh no” … then I thought "ok, actually it is nice to have the pads in an overview (even if it is kind of confusing), and the checklist-items are really useful.

So there is one element I think could be really helpful e.g.

: )

Structure, exports, inline comments, notifications (inc. mentions), invitations, links to headings, splitting documents.

At a later point common auth/SSO with discourse can be implemented

1 Like

A request: can we allow anonymous editing without sign-in in Hackpad?

It is very annoying to get the login-popup every time I want to correct a single typo…

And with my @student address, I only get “an error has occured. we’re looking into it.” when trying to log in :-/

Doesn’t it work when you choose the pad to be public (the link left to the pad title)?

This affected an existing pad (Scrum-in-Transformap) - there I don’t see a “public” switch?.

But it seems I’m logged in now? Strange thing…